"Сказки А.С. Пушкина".

1998-1999 уч. год

Проект выполнен учащимися Московской общеобразовательной средней школы ╧1178 Денисом Дашкевич 6Б, Александром Дорохиным 5В, Дмитрием Ледовским 5В, Алексеем Петровским 5В, Андреем Захаровым 5Г, Андреем Богомоловым 5Г, Ольгой Балашовой 8В и Надеждой Куминовой 8В под руководством преподавателя информатики Осипова Александра Михайловича.

Проект был посвящен 200-летию со дня рождения А.С. Пушкина и выполнен в форме игры угадайки, где играющий должен выбирать из предложенных вариантов правильные ответы, что дает ему возможность проходить дальше по сказке.

Разработчики проекта - учащиеся 5 - 6 классов, прочитав сказки А.С. Пушкина, выбрали по 2 - 3 эпизода из сказки. К каждому эпизоду нарисовали картинки, ввели текст из сказки, придумали вопросы и предложили варианты ответов. По мере возможности, каждый ученик разработал программы, которые приводили в движение героев сказок и оценивали правильность выбранного ответа. Таким образом получилось несколько самостоятельных проекто.

Учащиеся 8-х классов занимались объединением всех проектов в единое целое.

Проект выполнен в среде ЛогоМиры 1.01 на компьютерах Макинтош LCIII, и занимает объем около 1,4 мб.

Вашему вниманию предлагаются эпизоды из проекта (к сожалению в черно белом исполнении ) и некоторые отрывки из программного обеспечения.

 

 

 

 

 Программа перехода к новому проекту:

это переход1

возьми_проект "|Рыбка Дорохин|" возьми_лист "лист1

конец

Программа забрасывания невода:

это невод1

невод, нм[60 -60] нк 45 нф 15 нрз 10 пч

повтори 6 [повтори 4 [вп 2] нрз размер + 6] нк 90 повтори 6 [повтори 4 [вп 2] нрз размер + 6] нк 150 повтори 6 [повтори 4 [вп 2] нрз размер + 6] жди 20 сч

конец

Программа совместного движения лебедя и коршуна:

это движение

запусти [ дв-леб1] дв-кор1

запусти [дв-леб2] дв-кор2

конец